Re: More on IDL

Jayakumar Muthukumarasamy ([email protected])
Tue, 20 Dec 1994 09:49:38 -0500 (EST)

>
> To summarize, our convention is as follows:
>
> - Class names are capitalized, separate words separated with underscores.
> - Method names are lowe case, separated with underscores.
> -- get methods and set methods have the same name (overloading based on the
> paramters).
>
> We still need a convention for naming the iterators. We were using
> get_xx_iter, but since get methods are not called get_xxx, the iterators
> shouldn't have a get_ in front of them. Let's call the methods that return
> the itererators xxx_iter, and the iterator classes Xxx_Iter.
>

For readability sake, I am using the following convention for
iterators "Iterator(string), Iterator(short), etc", Iterator is a
parameterized macro, which expands to "string_Iterator". We could use this,
if it is OK with you. e.g.

interface Iinterface {
...
Iterator(Iattribute) attribute_iter();
...
};

-jk