GeoWorlds System Requirements

1) Requirements for GeoWorlds Client

   a) **Hardware Requirements:**

       You need an Windows NT or 2000 machine (or Windows 98, but not recommended) with at least 100Mb of hard drive space to install the software. You will probably need another 100Mb of disk space for the cache directory used to keep local copies of documents and map information commonly used in your information spaces. Therefore, we advise having around 250Mb of hard drive available to install and run GeoWorlds.

       We recommend that the CPU speed of the machine is 650MHz or faster, has 128Mb or more of RAM. The system performed poorly on machines with 32Mb of RAM, and okay on machines with 64Mb of RAM. Even though we strongly recommend using a 128Mb machine, the minimum requirement is 64Mb of RAM.

   b) **Software Requirements:**

       GeoWorlds use [ESRI ArcView](https://www.esri.com) software package as its GIS Map viewer. This software is required if you want to take advantage of the mapping capabilities and the map-to-document, document-to-map conversion features that GeoWorlds provides. However, GeoWorlds' document management components can still be used without ArcView. These include the advanced search capabilities, as well as clustering, analysis and categorization of documents retrieved from the web.
GeoWorlds Version 2.9.0 Quick Reference

This document describes the simplest way to perform a GeoWorlds analysis, which is to select and run one of the predefined “scripts”. Each script dispatches a set of search engines to collect a set of documents, and then applies a series of analysis services to those documents. Each script has a set of inputs that must be filled in before it can be run. Many scripts come with some of their inputs already filled-in, but you may modify any of these inputs. Most of the scripts generate more than one kind of output. Once an analysis has been performed, the outputs of the analysis can be inspected in any order.

For additional help:
Choose: Start → Program → GeoWorlds Version 2.9 → GeoWorlds 2.9 Help.

Table of Contents:

<table>
<thead>
<tr>
<th>GeoWorlds Quick Reference</th>
<th>................................................................. 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>1) To start GeoWorlds</td>
<td>........................................................................................................................................ 3</td>
</tr>
<tr>
<td>2) To use analysis scripts</td>
<td>........................................................................................................................................ 3</td>
</tr>
<tr>
<td>a) To bring up the Scripting tool:</td>
<td>........................................................................................................................................ 3</td>
</tr>
<tr>
<td>b) To select a Script:</td>
<td>........................................................................................................................................ 3</td>
</tr>
<tr>
<td>c) To select a different script:</td>
<td>........................................................................................................................................ 4</td>
</tr>
<tr>
<td>d) To run a script (to perform an analysis):</td>
<td>........................................................................................................................................ 4</td>
</tr>
<tr>
<td>e) To view the results of an analysis:</td>
<td>........................................................................................................................................ 4</td>
</tr>
<tr>
<td>f) To discard an analysis:</td>
<td>........................................................................................................................................ 5</td>
</tr>
<tr>
<td>g) To organize the results of an analysis:</td>
<td>........................................................................................................................................ 5</td>
</tr>
<tr>
<td>h) To save analysis results</td>
<td>........................................................................................................................................ 6</td>
</tr>
<tr>
<td>3) To enter input data for a script</td>
<td>........................................................................................................................................ 6</td>
</tr>
<tr>
<td>a) To enter a query to retrieve documents</td>
<td>........................................................................................................................................ 7</td>
</tr>
<tr>
<td>b) To enter a list of keywords:</td>
<td>........................................................................................................................................ 7</td>
</tr>
<tr>
<td>c) To enter a list of place names:</td>
<td>........................................................................................................................................ 7</td>
</tr>
<tr>
<td>4) To use the GIS map to retrieve a list of place names</td>
<td>........................................................................................................................................ 8</td>
</tr>
<tr>
<td>a) To create an incident:</td>
<td>........................................................................................................................................ 8</td>
</tr>
<tr>
<td>b) To define a geographical region of interest</td>
<td>........................................................................................................................................ 8</td>
</tr>
<tr>
<td>c) To load additional map layers:</td>
<td>........................................................................................................................................ 9</td>
</tr>
<tr>
<td>d) To gather the place names</td>
<td>........................................................................................................................................ 9</td>
</tr>
<tr>
<td>e) To save the incident</td>
<td>........................................................................................................................................ 10</td>
</tr>
</tbody>
</table>
1) To start GeoWorlds

Choose: Start → Program → GeoWorlds Version 2.9 → GeoWorlds 2.9 Client. GeoWorlds displays three windows: the GeoWorlds Client window, the Information Manager window, and the Arcview map window.

![Figure 1: GeoWorlds initial windows](image)

2) To use an analysis script

a) To bring up the Scripting tool:

Click on the Scripting Tool button at bottom of the Information Manager Window.

b) To select a Script:

Browse the scripts in the script hierarchy; select one by double-clicking. The right side of the script selection panel shows the hierarchy of available scripts. The left side shows details of the highlighted script.

![Figure 2: Scripting Tool (script selection mode)](image)
c) **To enter input data:**

At this point the upper frame shows the data flow between components in the script, and the lower frame shows directions (bottom left) on how to enter input data, and the input data forms (bottom right). Follow the directions to enter the data. The input forms may show default input data. Press the **Forward** button after entering the input data to go to the next input form. Press the **Back** button to go back to modify previous input forms. If you press **Back** button at the first input section, it will go to the script selection window.

![Scripting Tool (input & run mode)](image)

**Figure 3: Scripting Tool (input & run mode)**

d) **To run a script (to perform an analysis):**

After all the required input data have been filled in, the script is ready to run. Hit **Run** button to start executing the script. During script execution, the scripting tool display the progress of the entire script as well as the progress of individual analysis services.

e) **To view the results of an analysis:**

The execution of a script produces one or more “results”. These results are displayed in a new internal window with the heading “Document Analyzer”, that uses a tabbed display to present the collection of results. Press a tab to look at an individual result. Sometimes the Document Analyzer window gets buried under other windows. The “view” menu at the top of the Information Manager window lists all open Document
Analyzer windows (if you have run more than one script, then there will be more than one such window).

![Analyzer windows](image)

(a) Document mapping on ArcView  
(b) Document Analyzer

Figure 4: Script execution results

**f) To discard an analysis:**
Closing a Document Analyzer window discards that set of results.

**g) To organize the results of an analysis:**
There are two ways to organize the results. One is just to leave them as they are (in their own Document Analyzer window). The other way is to copy results or portions of results into a category hierarchy. This is done using a select/copy/paste operation. Individual documents may be selected by clicking on them (using “click”, “shift click”, or “control click”). Documents selected are highlighted. Typing the “control-a” command selects (and highlights) all documents under a tab. The highlighted collection is copied either by typing a “control-c” command, or by choosing Edit → Copy in the Information Manager window. After copying some documents in a result collection, shift your focus to the window labeled “Category Editors” inside of the Information Manager window. Click on the node in the hierarchy where you would like the documents to go, and then paste either by typing a “control-v” command, or by choosing Edit → Paste.
h) To save analysis results

The state that you build up during the execution of one or more analyses can be saved into a data structure called an “Information Space”. Information saved within each Information Space includes all the internal Information Manager window:

- The Category Editors window
- All the Document Analyzer windows

To save an information space, click on File → Save of Information Manager menu.
To load a saved information space, click on File → Open of Information Manager menu.

3) To enter input data for a script

Synopsis:

At this point we assume that you have selected a script, the GeoWorlds Scripting Tool window is displaying a graph of that script across the top of the window, and descriptions of inputs to the script appear as pink boxes stacked vertically along the left side of the window. Any unchecked pink boxes represent inputs that are currently blank and must be filled in before the script can be run. Optionally, you may change any of the already-filled-in input data. Select the input that you wish to edit by double-clicking on a (pink) box. A customized editor for that input will be displayed in the lower-right frame of the window. Sections 3a, 3b, and 3c describe how to use each of the three types of editors.
a) To enter a query to retrieve documents

The first input box asks for a set of keywords that will be fed to the search engines that retrieve an initial collection of documents. Clicking on this box brings up a small window entitled “Search Engine Query Tool”. Enter one or more keywords in the box marked “Query”. Optionally, you may deselect some of the search engines used to retrieve documents, and you may change the number of documents that each search engine retrieves (the initial number is 20).

b) To enter a list of keywords

The “Keyword Editor” displays a list of zero or more keywords that are used to partition an intermediate result within an analysis. To add an additional keyword, hit the add item button (➕) and type in your keyword. When done hit the “enter” key, or hit “control-enter” to add another keyword. Hitting the remove button (➖) deletes a keyword. When you are satisfied with your list of keywords, hit the OK button.

Alternatively, instead of typing in each keyword, you may select from a predefined set of keyword sets. To do this, hit the open folder button (📂) at the bottom of the window, make a selection, and then hit open. Once the keywords have been loaded, you can edit them if you like, and then hit OK.

c) To enter a list of place names

The “Place Name Editor” allows one to specify a set of place names that will be used to partition an intermediate result within an analysis. The Place Name editor offers the same two editing alternatives as the Keyword Editor (see 3b), except that along with each place you specify, you must also supply a lat/long coordinate.

Also, you can use a map GIS viewer to retrieve a list of place names. Go to step 4. Once you have retrieved the list from a
map, click on the load place names exported from the GIS viewer button (🌏). Note: sometimes you may have to click on this button twice.

4) To use the GIS map to retrieve a list of place names

Strictly speaking only steps b) and d) below are needed to retrieve a list of place names. The other steps are useful if you want to enhance the map display with additional map layers, and to be able to automatically reload the map layers using the incident mechanism.

a) To create an incident

To create an incident click the new incident button (.addButton) located on the GeoWorlds toolbar (top of the screen). This creates a new incident with default incident information. Click on the edit incident properties button (/edit) to type in a name and an incident type for this new incident. To load previously saved incidents use the load incident button (load).

b) To define a geographical region of interest

Pick the region of interest drawing tool button (region) located within the GIS Map viewer. Your cursor should change into a crosshair type. Click on the view to define vertices of an arbitrary polygon and double click to close the polygon.

Tip: double clicking on a point in the view while the "Region of Interest" drawing tool has been selected will construct a region enveloping the smallest administrative boundary that contains that point. This way rather than drawing a region by clicking a polygon around, say California, we can double-click any point inside the state of California to form a "Region Of Interest" exactly equal to its boundary.
c) To load additional map layers

Having drawn the region of interest, click on the query map data warehouse button to select additional map layers. Each icon on the left-hand side of the dialog window represents a map layer that intersects with the region of interest. The right-hand side of the dialog window contains a brief description of the selected layer. To mark a map layer for download double-click on the map layer icon.

![Figure 11: Selecting additional map layers](image)


d) To gather the place names

Click on the export place names button to export place names to the Information Manager. A dialog window listing all the map layers will pop up. Select map layers from which you wish to export place names. Typically, good map layers to select are the World Location and Gazetteer layers. After selecting the layers, all names belonging to the selected layers falling within the region of Incident are displayed.

All or a subset of the above displayed names can be selected for export to the Information manager component of GeoWorlds. On clicking ok in the displayed dialog box, the GIS Viewer component asks the user if they wish these selected names to be merged with previously exported names or just replace the previously exported names. This is useful when building a large list of names. As there is a limit on the number of names that Arcview will export, it is often better to pick small regions at a time to export names from.

Note: Selecting a region which is likely to contain thousands of geographic entities is not advisable as the extraction and export of this
list of names would consume a large amount of resources leading to unpredictable behavior in the system.

e) **To save the incident**

Click on the **save incident** button (位于GeoWorlds toolbar to save the incident. Information saved within each incident includes:

- The name of the incident
- The type of the incident
- The region of interest
- The map layers loaded from the data warehouse